Sunday, December 6, 2015

BGP advanced task #1. Fast convergence

Topology:


Requirements:

Routers R1, R2 and R3 are configured in OSPF area 0. 
Configure iBGP session between R1 and R3, use loopback addresses for peering. 
Configure R3 to advertise default route into OSPF. 
Configure routers R1 and R3 to close the iBGP session as fast as possible, once the neighbor becomes unreachable. 
Do not adust BGP timers and do not use BFD to complete the task. 


Solution:

Highlight the text below to reveal the solution.

Fast Session Deactivation should be configure to achieve the requirements.
Once route to neighbor is removed by the IGP, the iBGP session is immediately closed.
Since R3 originates a default route into OSPF, R1 need to be configured to only track host route to peer (3.3.3.3/32), otherwise it won't be able to detect the route loss to peer, because of the presence of the default route.

Note: It looks like this feature is not supported in IOS-XR. R3:


R1:

!
router bgp 123
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 123
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 fall-over route-map TRACK
!
ip prefix-list TRACK seq 5 permit 3.3.3.3/32
!
route-map TRACK permit 100
match ip address prefix-list TRACK
!


R3:

!
router ospf 1
default-information originate always
!
router bgp 123
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 123
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 fall-over
!

Verification:


Shutting down loopback interface on R3:

R3(config-if)#
*Dec 6 11:16:47.940: %LINK-5-CHANGED: Interface Loopback0, changed state to administratively down
*Dec 6 11:16:48.948: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to down

R1#
*Dec 6 11:16:51.455: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down Route to peer lost
*Dec 6 11:16:51.455: %BGP_SESSION-5-ADJCHANGE: neighbor 3.3.3.3 IPv4 Unicast topology base removed from session Route to peer lost










No comments:

Post a Comment