Wednesday, January 6, 2016

ISIS task #3. Multi Area topology - continued

Topology:



Use configuration from ISIS task #2 as initial configuration for this task.

Requirements: 

1. Configure the network, so traffic between any two loopback0 interfaces must use the shortest path available. You are allowed to change interface metrics, but not allowed to change the ISIS areas assignment. 
2. Reduce network resources used for LSP refresh.
3. Configure SPF and PRC throttling to the half of their default values.
4. On R1-R3 segment, configure the DIS to send Hello every second.
5. On R1-R3 segment, configure the DIS to flood CSNP every 5 seconds. 
6. Configure interfaces loopback16 and loopback17 on R8. Set ipv4 addresses to 11.0.16.16/24 and         11.0.17.17/24.  Configure those loopback interfaces as passive ISIS interfaces. Other Level-2              routers should only have one entry in routing table to reach those two networks. 

Solution:

Highlight the text below to reveal the solution.

Requirement #1 - set metric of R1-R2 segment interfaces back to default value of 10. Configure Level-2 to Level-1 leaking for loopback0 addresses only. This allows the routers in Area 3 to calculate the optimal best route, instead of using the default route to Level-2 routers.

Requirement #2 - use recommended Cisco values, max-lsp-lifetime of 65535 and lsp-refresh-interval of 65500

Requirement #3 - Default SPF and RPC throttling values are 10 seconds max-wait and 5.5 seconds for initial and second wait.

Requirement #4 - DIS Hello is 1/3 the configured Hello interval, so configure the Hello interval to 3 seconds.

Requirement #5 - interface level csnp-flood configuration command.

Requirement #6 - configure the interfaces as passive, and configure summary-address on R8.

R1:

!
interface Ethernet0/1
 ip address 11.0.12.1 255.255.255.0
 ip router isis CCIE
 isis circuit-type level-2-only
 isis network point-to-point
!
router isis CCIE
 net 49.0001.0000.0000.0001.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!

R2:

!
interface Ethernet0/1
 ip address 11.0.12.2 255.255.255.0
 ip router isis CCIE
 isis circuit-type level-2-only
 isis network point-to-point
!
router isis CCIE
 net 49.0001.0000.0000.0002.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!

R3:


!
router isis CCIE
 net 49.0001.0000.0000.0003.00
 lsp-refresh-interval 65000
 max-lsp-lifetime 65535
 lsp-password keychain CHAIN level 2
 address-family ipv4 unicast
  default-information originate
 !
..
!

R4: 


!
router isis CCIE
 net 49.0003.0000.0000.0004.00
 authentication mode text level-1
 authentication mode md5 level-2
 authentication key-chain CHAIN2 level-1
 authentication key-chain CHAIN level-2
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
 redistribute isis ip level-2 into level-1 route-map LEAK
!
!
ip prefix-list LOOPBACKS seq 5 permit 11.0.1.1/32
ip prefix-list LOOPBACKS seq 10 permit 11.0.2.2/32
ip prefix-list LOOPBACKS seq 15 permit 11.0.3.3/32
ip prefix-list LOOPBACKS seq 20 permit 11.0.8.8/32
!
!
route-map LEAK permit 10
 match ip address prefix-list LOOPBACKS
!

R5:

!
router isis CCIE
 net 49.0003.0000.0000.0005.00
 lsp-refresh-interval 65000
 max-lsp-lifetime 65535
 lsp-password text encrypted 047A39232E72 level 1
 lsp-password keychain CHAIN level 2
 address-family ipv4 unicast
  propagate level 2 into level 1 route-policy LEAK
 !
..
!
prefix-set LOOPBACKS
  11.0.1.1/32,
  11.0.2.2/32,
  11.0.3.3/32,
  11.0.8.8/32
end-set
!
route-policy LEAK
  if destination in LOOPBACKS then
    pass
  endif
end-policy
!

R6:

!
router isis CCIE
 net 49.0003.0000.0000.0006.00
 is-type level-1
 area-password AREA3 authenticate snp validate
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!

R7: 


!
router isis CCIE
 net 49.0003.0000.0000.0007.00
 is-type level-1
 area-password AREA3 authenticate snp validate
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!


R8:

!
interface Loopback16
 ip address 11.0.16.16 255.255.255.0
!
interface Loopback17
 ip address 11.0.17.17 255.255.255.0
!
router isis CCIE
 net 49.0002.0000.0000.0008.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
 summary-address 11.0.16.0 255.255.254.0
 passive-interface Loopback16
 passive-interface Loopback17
!


Verification:

R1#sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 11.0.13.3 to network 0.0.0.0

i*L2  0.0.0.0/0 [115/10] via 11.0.13.3, 20:56:44, Ethernet0/0
      11.0.0.0/8 is variably subnetted, 23 subnets, 3 masks
i L2     11.0.2.2/32 [115/20] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.3.3/32 [115/20] via 11.0.13.3, 20:56:44, Ethernet0/0
i L2     11.0.4.4/32 [115/30] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.5.5/32 [115/30] via 11.0.13.3, 20:25:11, Ethernet0/0
i L2     11.0.6.6/32 [115/40] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.7.7/32 [115/40] via 11.0.13.3, 16:14:17, Ethernet0/0
                     [115/40] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.8.8/32 [115/20] via 11.0.18.8, 1d19h, Ethernet1/0
i L2     11.0.16.0/23 [115/10] via 11.0.18.8, 00:18:05, Ethernet1/0
i L2     11.0.23.0/24 [115/20] via 11.0.13.3, 16:14:17, Ethernet0/0
                      [115/20] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.24.0/24 [115/20] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.35.0/24 [115/20] via 11.0.13.3, 20:56:44, Ethernet0/0
i L2     11.0.45.0/24 [115/30] via 11.0.13.3, 16:14:17, Ethernet0/0
                      [115/30] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.46.0/24 [115/30] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.47.0/24 [115/30] via 11.0.12.2, 16:14:17, Ethernet0/1
i L2     11.0.57.0/24 [115/30] via 11.0.13.3, 20:25:11, Ethernet0/0
i L2     11.0.67.0/24 [115/40] via 11.0.13.3, 16:14:17, Ethernet0/0
                      [115/40] via 11.0.12.2, 16:14:17, Ethernet0/1


R6#sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 11.0.46.4 to network 0.0.0.0

i*L1  0.0.0.0/0 [115/10] via 11.0.46.4, 20:53:02, Ethernet0/1
      11.0.0.0/8 is variably subnetted, 17 subnets, 2 masks
i ia     11.0.1.1/32 [115/168] via 11.0.46.4, 16:15:17, Ethernet0/1
i ia     11.0.2.2/32 [115/158] via 11.0.46.4, 16:33:39, Ethernet0/1
i ia     11.0.3.3/32 [115/168] via 11.0.67.7, 16:17:30, Ethernet0/0
                     [115/168] via 11.0.46.4, 16:17:30, Ethernet0/1
i L1     11.0.4.4/32 [115/20] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.5.5/32 [115/30] via 11.0.67.7, 20:53:02, Ethernet0/0
                     [115/30] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.7.7/32 [115/20] via 11.0.67.7, 20:53:02, Ethernet0/0
i ia     11.0.8.8/32 [115/178] via 11.0.46.4, 16:15:17, Ethernet0/1
i L1     11.0.24.0/24 [115/20] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.35.0/24 [115/30] via 11.0.67.7, 20:53:02, Ethernet0/0
                      [115/30] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.45.0/24 [115/20] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.47.0/24 [115/20] via 11.0.67.7, 20:53:02, Ethernet0/0
                      [115/20] via 11.0.46.4, 20:53:02, Ethernet0/1
i L1     11.0.57.0/24 [115/20] via 11.0.67.7, 20:53:02, Ethernet0/0


R7#  sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 11.0.57.5 to network 0.0.0.0

i*L1  0.0.0.0/0 [115/10] via 11.0.57.5, 20:56:15, Ethernet0/1
                [115/10] via 11.0.47.4, 20:56:15, Ethernet0/2
      11.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
i ia     11.0.1.1/32 [115/168] via 11.0.57.5, 16:14:58, Ethernet0/1
                     [115/168] via 11.0.47.4, 16:14:58, Ethernet0/2
i ia     11.0.2.2/32 [115/158] via 11.0.47.4, 16:33:21, Ethernet0/2
i ia     11.0.3.3/32 [115/158] via 11.0.57.5, 16:17:12, Ethernet0/1
i L1     11.0.4.4/32 [115/20] via 11.0.47.4, 20:56:15, Ethernet0/2
i L1     11.0.5.5/32 [115/20] via 11.0.57.5, 21:09:34, Ethernet0/1
i L1     11.0.6.6/32 [115/20] via 11.0.67.6, 20:52:41, Ethernet0/0
i ia     11.0.8.8/32 [115/178] via 11.0.57.5, 16:14:58, Ethernet0/1
                     [115/178] via 11.0.47.4, 16:14:58, Ethernet0/2
i L1     11.0.24.0/24 [115/20] via 11.0.47.4, 20:56:15, Ethernet0/2
i L1     11.0.35.0/24 [115/20] via 11.0.57.5, 21:09:34, Ethernet0/1
i L1     11.0.45.0/24 [115/20] via 11.0.57.5, 20:56:15, Ethernet0/1
                      [115/20] via 11.0.47.4, 20:56:15, Ethernet0/2
i L1     11.0.46.0/24 [115/20] via 11.0.67.6, 20:52:41, Ethernet0/0
                      [115/20] via 11.0.47.4, 20:52:41, Ethernet0/2



R8#sh ip route isis
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 11.0.18.1 to network 0.0.0.0

i*L2  0.0.0.0/0 [115/20] via 11.0.18.1, 20:57:22, Ethernet0/0
      11.0.0.0/8 is variably subnetted, 25 subnets, 3 masks
i L2     11.0.1.1/32 [115/20] via 11.0.18.1, 21:00:30, Ethernet0/0
i L2     11.0.2.2/32 [115/30] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.3.3/32 [115/30] via 11.0.18.1, 20:57:22, Ethernet0/0
i L2     11.0.4.4/32 [115/40] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.5.5/32 [115/40] via 11.0.18.1, 20:25:49, Ethernet0/0
i L2     11.0.6.6/32 [115/50] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.7.7/32 [115/50] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.12.0/24 [115/20] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.13.0/24 [115/20] via 11.0.18.1, 21:00:30, Ethernet0/0
i su     11.0.16.0/23 [115/0] via 0.0.0.0, 00:18:45, Null0
i L2     11.0.23.0/24 [115/30] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.24.0/24 [115/30] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.35.0/24 [115/30] via 11.0.18.1, 20:57:22, Ethernet0/0
i L2     11.0.45.0/24 [115/40] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.46.0/24 [115/40] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.47.0/24 [115/40] via 11.0.18.1, 16:14:55, Ethernet0/0
i L2     11.0.57.0/24 [115/40] via 11.0.18.1, 20:25:49, Ethernet0/0
i L2     11.0.67.0/24 [115/50] via 11.0.18.1, 16:14:55, Ethernet0/0

No comments:

Post a Comment