Monday, December 14, 2015

OSPF task #3. Multiple areas OSPF

Topology:


Use configuration from task OSPF #2 as initial configuration for this task.

Requirements:

1. Configure the following interfaces in OSPF area 4:
           Link R5 to R7
           Link R4 to R6
           Link R7 to R6
           Loobpack0 interfaces of R7 and R6

2 . Configuration shall be redundant. Single device failure shall not lead to loss of connectivity to other parts of the network.

3. Only one virtual link is allowed to complete this task. 


Solution: 

Highlight the text below to reveal the solution. 

Reconfigure Area 3 as "normal" (non NSSA) area. 
Area 4 has no direct connection to Area 0, and virtual-links are required to connect those. 
In order to provide redundancy, two virtual links required - one between R3 to R5, and second between R2 to R4. Since only single virtual-link is allowed, second virtual-link can be replaced with GRE tunnel. 

R3:

!
router ospf 1
 router-id 10.0.3.3
 area 0
  interface Loopback0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/0
   authentication message-digest
   message-digest-key 1 md5 encrypted 122A31253D252B
   network non-broadcast
   priority 254
   neighbor 10.0.13.1
  !
  interface GigabitEthernet0/0/0/1
   authentication-key encrypted 0802606B282B
   authentication
   network broadcast
   priority 255
  !
 !
 area 3
  range 10.0.4.0/23 advertise
  virtual-link 10.0.5.5
  !
  interface GigabitEthernet0/0/0/2
  !
 !
!

R4: 

!
interface Ethernet1/0
 ip address 10.0.46.4 255.255.255.0
 ip ospf 1 area 4
!
!
interface Tunnel42
 ip address 10.0.42.4 255.255.255.0
 ip ospf 1 area 4
 keepalive 10 3
 tunnel source 10.0.4.4
 tunnel destination 10.0.2.2
!

R5:

router ospf 1
 area 3
  virtual-link 10.0.3.3
  !
  interface Loopback0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
  !
  interface GigabitEthernet0/0/0/2
  !
 !
 area 4
  interface GigabitEthernet0/0/0/0
  !
 !
!

R6:

!
interface Ethernet0/0
 ip address 10.0.67.6 255.255.255.0
 ip ospf 1 area 4
!
interface Ethernet0/1
 ip address 10.0.46.6 255.255.255.0
 ip ospf 1 area 4
!
interface Loopback0
 ip address 10.0.6.6 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 4
!
router ospf 1
 router-id 10.0.6.6
!

R7:

!
interface Ethernet0/0
 ip address 10.0.67.7 255.255.255.0
 ip ospf 1 area 4
!
interface Ethernet0/1
 ip address 10.0.57.7 255.255.255.0
 ip ospf 1 area 4
!
interface Loopback0
 ip address 10.0.7.7 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 4
!
router ospf 1
 router-id 10.0.7.7
!

2 comments:

  1. Something's wrong here with the solution.

    First, the tunnel should be bidirectional. Next, it should be announced as area 0, not area 4, since the matter is to form an area 0 adjacency (same as with a virtual link). Last but most important, the tunnel endpoints should not be advertised into OSPF, otherwise the adjacency would constantly flap due to a loop in recursion.

    Also, removal of the NSSA area should be requested in the task, not in the solution. Otherwise the reader basically struggles with the impossibility to accomplish the task - a virtual link would not be available through a NSSA. By the way, the GRE tunnel would work just fine in that case, so the task could be "leave the NSSA intact, and create as many VL's as you wish". In that case the solution would be to create two tunnels, since the VL's would not be available in the config.


    ReplyDelete
    Replies
    1. Hi Anton,

      Thanks again for your comment!

      Correct, the tunnel is indeed bidirectional. Configuration of R2 router which is the endpoint of the tunnel is missing from the solutions.

      Best regards,
      Dimitry

      Delete