Tuesday, December 15, 2015

OSPF task #4. Redistribution

Topology:



Use configuration from task OSPF #3 as initial configuration for this task.

Requirements:


1. Remove OSPF area 4 configuration from previous task. 
2. Configure EIGRP autonomous-system 100 on the following links:
         R5-R7
         R6-R7
         R4-R6
         Loopback0 interfaces of R6 & R7.

3. Routers in Area 0 and Area 2 shall all have metric of 15 for R6 loopback0 address.
4. Routers in Area 0 and Area 2 shall use shortes (in terms of OSPF metric) path towards R7 loopback0 address.  
5. Network 10.0.67/24 should be reachable from Area 3, but should not be reachable from the rest of OSPF domain. 

Solution:

Highlight the text below to reveal the solution.

Solution requires understanding of OSPF NSSA area, external route types and summary-address command.

1. Remove Area 4 definition, virtual-link and Tunnel 42 interface. 
2. Make sure R5's Area 0 LSAs are purged from Area 0 - those have DNA bit set. Shut down, then restart all devices in Area 0 and R5. 
3. Area 3 need to be reconfigured as NSSA area to achieve requirement #5. Change Area 2 to normal area instead of stub. 
4. Redistribute R6 loopback0 address as type E2 with metric 15.
Redistribute R7 loopback0 address as type E1. 
5. On R3 and R2, configure "summary-address 10.0.67.0/24 no-advertise". In NSSA area, "no-advertise" option will prevent ASBRs from translating Type-7 LSA to Type-5, thus prefix 10.0.67.0/24 will not be advertised into area 0. 

R2:

!
router ospf 1
 router-id 10.0.2.2
 area 3 nssa
 summary-address 10.0.67.0 255.255.255.0 not-advertise
!

R3:

!
router ospf 1
 summary-prefix 10.0.67.0/24 not-advertise
 area 0
  interface GigabitEthernet0/0/0/0
   authentication message-digest
   message-digest-key 1 md5 encrypted 04683F34200F6B
   network non-broadcast
   neighbor 10.0.13.1
  !
  interface GigabitEthernet0/0/0/1
   authentication-key encrypted 13263B372A3E
   authentication
  !
 !
 area 3
  nssa
  interface GigabitEthernet0/0/0/2
  !
 !
!

R4:

!
router ospf 1
 area 3 nssa
 redistribute eigrp 100 subnets route-map REDIST
!
router eigrp NAMED
 !
 address-family ipv4 unicast autonomous-system 100
  !
  topology base
   redistribute ospf 1 metric 10000 1 255 1 1500
  exit-af-topology
  network 10.0.46.4 0.0.0.0
 exit-address-family
!
!
ip prefix-list R67 seq 5 permit 10.0.67.0/24
!
ip prefix-list R6L seq 5 permit 10.0.6.6/32
!
ip prefix-list R7L seq 5 permit 10.0.7.7/32
!
route-map REDIST permit 10
 match ip address prefix-list R6L
 set metric 15
 set metric-type type-2
!
route-map REDIST permit 20
 match ip address prefix-list R7L
 set metric-type type-1
!
route-map REDIST permit 30
 match ip address prefix-list R67
!

R5:

!
prefix-set R67
  10.0.67.0/24
end-set
!
prefix-set R6L
  10.0.6.6/32
end-set
!
prefix-set R7L
  10.0.7.7/32
end-set
!
route-policy REDIST
  if destination in R6L then
    set metric-type type-2
    set ospf-metric 15
  endif
  if destination in R7L then
    set metric-type type-1
  endif
  if destination in R67 then
    pass
  endif
end-policy
!
route-policy OSPF_2_EIGRP
  set eigrp-metric 10000 1 255 1 1500
end-policy
!
router ospf 1
 redistribute eigrp 100 route-policy REDIST
 area 3
  nssa
  interface Loopback0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
  !
  interface GigabitEthernet0/0/0/2
  !
 !
!
router eigrp 100
 address-family ipv4
  router-id 10.0.5.5
  redistribute ospf 1 route-policy OSPF_2_EIGRP
  interface GigabitEthernet0/0/0/0
  !
 !
!

R6:

!
router eigrp NAMED
 !
 address-family ipv4 unicast autonomous-system 100
  !
  topology base
  exit-af-topology
  network 10.0.6.6 0.0.0.0
  network 10.0.46.6 0.0.0.0
  network 10.0.67.6 0.0.0.0
 exit-address-family
!

R7:

!
router eigrp NAMED
 !
 address-family ipv4 unicast autonomous-system 100
  !
  topology base
  exit-af-topology
  network 10.0.7.7 0.0.0.0
  network 10.0.57.7 0.0.0.0
  network 10.0.67.7 0.0.0.0
 exit-address-family
!

Verification:


R1#sh ip rou
R1#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 17 subnets, 2 masks
O        10.0.2.2/32 [110/11] via 10.0.12.2, 22:20:39, Ethernet0/1
O IA     10.0.4.4/32 [110/21] via 10.0.12.2, 00:08:24, Ethernet0/1
O IA     10.0.5.5/32 [110/21] via 10.0.13.3, 00:05:04, Ethernet0/0
O E2     10.0.6.6/32 [110/15] via 10.0.13.3, 00:05:04, Ethernet0/0
O E1     10.0.7.7/32 [110/41] via 10.0.13.3, 00:05:04, Ethernet0/0
O        10.0.8.8/32 [110/11] via 10.0.18.8, 22:20:39, Ethernet1/0
O        10.0.23.0/24 [110/20] via 10.0.13.3, 17:32:30, Ethernet0/0
                      [110/20] via 10.0.12.2, 22:20:39, Ethernet0/1
O IA     10.0.24.0/24 [110/20] via 10.0.12.2, 22:20:21, Ethernet0/1
O IA     10.0.35.0/24 [110/20] via 10.0.13.3, 17:32:30, Ethernet0/0
O IA     10.0.45.0/24 [110/30] via 10.0.13.3, 00:05:04, Ethernet0/0
                      [110/30] via 10.0.12.2, 00:08:24, Ethernet0/1


R2#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 18 subnets, 2 masks
O        10.0.1.1/32 [110/11] via 10.0.12.1, 22:20:40, Ethernet0/1
O        10.0.4.4/32 [110/11] via 10.0.24.4, 00:08:43, Ethernet1/0
O        10.0.5.5/32 [110/21] via 10.0.24.4, 00:05:49, Ethernet1/0
O N2     10.0.6.6/32 [110/15] via 10.0.24.4, 00:06:41, Ethernet1/0
O N1     10.0.7.7/32 [110/31] via 10.0.24.4, 00:07:05, Ethernet1/0
O IA     10.0.8.8/32 [110/21] via 10.0.12.1, 22:20:40, Ethernet0/1
O        10.0.13.0/24 [110/20] via 10.0.23.3, 17:32:49, Ethernet0/0
                      [110/20] via 10.0.12.1, 22:20:40, Ethernet0/1
O IA     10.0.18.0/24 [110/20] via 10.0.12.1, 22:20:40, Ethernet0/1
O        10.0.35.0/24 [110/30] via 10.0.24.4, 00:05:18, Ethernet1/0
O        10.0.45.0/24 [110/20] via 10.0.24.4, 00:08:43, Ethernet1/0
O N2     10.0.67.0/24 [110/20] via 10.0.24.4, 00:07:05, Ethernet1/0



2 comments:

  1. Hi Dimitry, a couple of minor comments here as well.

    Task 3 should, strictly speaking, exclude "Area 2" from formulation, because R8 is a stub (from previous tasks), so he sees just the default route without any more specific metrics.

    And also, R3 still has the summary route for Area 3 loopbacks (from previous tasks), so the routing remains suboptimal (from the perspective of the OSPF metric). To fulfil task 4, one should remove that summary route (or its removal could be specified in the initial conditions).

    ReplyDelete
    Replies
    1. Hi Anton,

      Thank you for your feedback. I've updated the solution. Note that removal of the summary is part of the solution for the task.

      In order not to expose solution in the comments of the task page, I am adding a new "Comments" page.

      Best regards,
      Dimitry

      Delete