Monday, January 22, 2018

BFD task #2. BFD for BGP.

Topology:



Use configuration from BFD task #1 as initial configuration for this task.
Router R6 is added to the topology. 

Requirements: 

1. Configure link between routers R6 and R4. 
2. Configure eBGP session between routers R4 and R6. 
3. Configure full-mesh of iBGP sessions between routers in AS24. Use loopback0 addresses for             iBGP peerings. 
4. Configure all BGP sessions for sub-second convergence. Don't change BGP session timers. 
5. When possible, reduce the load on routers CPU introduced by BFD, by only processing BFD               packets every 20 seconds. 

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of BFD configuration for BGP, multihop BFD configuration, and BFD slow-timers.

Requirement #4 - use multihop-BFD to activate BFD for iBGP peerings. You will need to configure bfd-multihop template and bfd map, then configure the BGP peers for BFD.

Requiremetn #5 - configure BFD slow-timers with value of 20000 msec. This will reduce the rate of BFD control packets to every 20 seconds, instead of every 1 second, but only for BFD sessions in echo mode.

R1, R2, R3, & R5: 


!
bfd slow-timers 20000
bfd map ipv4  24.0.0.0/16  24.0.0.0/16 MH
bfd-template multi-hop MH
 interval min-tx 250 min-rx 250 multiplier 3
!
!
router bgp 24
 bgp log-neighbor-changes
 neighbor IBGP peer-group
 neighbor IBGP remote-as 24
 neighbor IBGP update-source Loopback0
 neighbor IBGP fall-over bfd
 ..
 ..
!

R4:


bfd slow-timers 20000
bfd map ipv4  24.0.0.0/16  24.0.0.0/16 MH
bfd-template multi-hop MH
 interval min-tx 250 min-rx 250 multiplier 3
!
!
interface Ethernet1/0
 ip address 24.0.46.4 255.255.255.0
 bfd interval 250 min_rx 250 multiplier 3
!
!
router bgp 24
 bgp log-neighbor-changes
 neighbor IBGP peer-group
 neighbor IBGP remote-as 24
 neighbor IBGP update-source Loopback0
 neighbor IBGP fall-over bfd
 neighbor 24.0.1.1 peer-group IBGP
 neighbor 24.0.2.2 peer-group IBGP
 neighbor 24.0.3.3 peer-group IBGP
 neighbor 24.0.5.5 peer-group IBGP
 neighbor 24.0.46.6 remote-as 6
 neighbor 24.0.46.6 fall-over bfd
!



R6:


!
interface Ethernet0/0
 ip address 24.0.46.6 255.255.255.0
 bfd interval 250 min_rx 250 multiplier 3
!
!
router bgp 6
 bgp log-neighbor-changes
 neighbor 24.0.46.4 remote-as 24
 neighbor 24.0.46.4 fall-over bfd
!

Verification:


R1#               show bfd neighbors

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.2                               3/3          Up        Up        Et0/0
24.0.10.3                               2/2          Up        Up        Et0/0
24.0.40.5                               1/2          Up        Up        Et0/1

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.2.2                                       4/5          Up        Up
24.0.3.3                                       5/6          Up        Up
24.0.4.4                                       9/5          Up        Up
24.0.5.5                                       8/9          Up        Up


R1#               show bfd neighbors  details

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.2                               3/3          Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.10.1
Handle: 3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 20000000, MinRxInt: 20000000, Multiplier: 3
Received MinRxInt: 20000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 20000(8609)
Rx Count: 8613, Rx Interval (ms) min/max/avg: 1/19954/1677 last: 3448 ms ago
Tx Count: 8614, Tx Interval (ms) min/max/avg: 1/19983/1661 last: 17741 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 02:20:18
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 3                - Your Discr.: 3
             Min tx interval: 20000000   - Min rx interval: 20000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.3                               2/2          Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.10.1
Handle: 2
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 20000000, MinRxInt: 20000000, Multiplier: 3
Received MinRxInt: 20000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 20000(8611)
Rx Count: 8629, Rx Interval (ms) min/max/avg: 1/20002/1676 last: 321 ms ago
Tx Count: 8616, Tx Interval (ms) min/max/avg: 1/19924/1665 last: 13155 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 02:20:21
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 2                - Your Discr.: 2
             Min tx interval: 20000000   - Min rx interval: 20000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.40.5                               1/2          Up        Up        Et0/1
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.40.1
Handle: 1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 718(0), Hello (hits): 250(37946)
Rx Count: 37960, Rx Interval (ms) min/max/avg: 24/281/221 last: 33 ms ago
Tx Count: 37948, Tx Interval (ms) min/max/avg: 1/294/221 last: 15 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 02:20:21
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 2                - Your Discr.: 1
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.2.2                                       4/5          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.1.1
Handle: 5
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 548(0), Hello (hits): 250(11709)
Rx Count: 4233, Rx Interval (ms) min/max/avg: 1/271/222 last: 202 ms ago
Tx Count: 4227, Tx Interval (ms) min/max/avg: 1/258/221 last: 105 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:15:37
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 5                - Your Discr.: 4
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.3.3                                       5/6          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.1.1
Handle: 4
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 680(0), Hello (hits): 250(11679)
Rx Count: 4179, Rx Interval (ms) min/max/avg: 1/258/222 last: 70 ms ago
Tx Count: 4180, Tx Interval (ms) min/max/avg: 1/267/222 last: 220 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:15:27
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 6                - Your Discr.: 5
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.4.4                                       9/5          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.1.1
Handle: 6
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 681(0), Hello (hits): 250(4444)
Rx Count: 4154, Rx Interval (ms) min/max/avg: 16/260/222 last: 69 ms ago
Tx Count: 4149, Tx Interval (ms) min/max/avg: 2/258/222 last: 100 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:15:20
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 5                - Your Discr.: 9
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.5.5                                       8/9          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.1.1
Handle: 7
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 693(0), Hello (hits): 250(5825)
Rx Count: 5821, Rx Interval (ms) min/max/avg: 1/267/222 last: 57 ms ago
Tx Count: 5828, Tx Interval (ms) min/max/avg: 1/257/221 last: 192 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:21:31
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 9                - Your Discr.: 8
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0


R4#                     show bfd neighbors

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.20.3                               2/5          Up        Up        Et0/0
24.0.20.5                               1/12         Up        Up        Et0/0
24.0.30.2                               3/4          Up        Up        Et0/1
24.0.46.6                               4/1          Up        Up        Et1/0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.1.1                                       5/9          Up        Up
24.0.2.2                                       6/7          Up        Up
24.0.3.3                                       7/8          Up        Up
24.0.5.5                                       8/13         Up        Up
R4#sho
R4#show bf
R4#show bfd nei
R4#show bfd neighbors deta
R4#show bfd neighbors details

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.20.3                               2/5          Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.20.4
Handle: 2
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 20000000, MinRxInt: 20000000, Multiplier: 3
Received MinRxInt: 20000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 20000(214)
Rx Count: 221, Rx Interval (ms) min/max/avg: 1/19993/5860 last: 9513 ms ago
Tx Count: 218, Tx Interval (ms) min/max/avg: 1/19861/5915 last: 15078 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:21:38
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 5                - Your Discr.: 2
             Min tx interval: 20000000   - Min rx interval: 20000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.20.5                               1/12         Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.20.4
Handle: 1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 20000000, MinRxInt: 20000000, Multiplier: 3
Received MinRxInt: 20000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 20000(217)
Rx Count: 223, Rx Interval (ms) min/max/avg: 1/20007/5797 last: 15649 ms ago
Tx Count: 222, Tx Interval (ms) min/max/avg: 1/19984/5883 last: 2565 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:21:42
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 12               - Your Discr.: 1
             Min tx interval: 20000000   - Min rx interval: 20000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.30.2                               3/4          Up        Up        Et0/1
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.30.4
Handle: 7
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 577(0), Hello (hits): 250(5844)
Rx Count: 5839, Rx Interval (ms) min/max/avg: 2/258/222 last: 173 ms ago
Tx Count: 5847, Tx Interval (ms) min/max/avg: 1/261/221 last: 65 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:21:33
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 4                - Your Discr.: 3
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.46.6                               4/1          Up        Up        Et1/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.46.4
Handle: 8
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 20000000, MinRxInt: 20000000, Multiplier: 3
Received MinRxInt: 20000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 20000(64)
Rx Count: 66, Rx Interval (ms) min/max/avg: 1/19989/17146 last: 15620 ms ago
Tx Count: 65, Tx Interval (ms) min/max/avg: 15130/19968/17532 last: 8095 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Uptime: 00:18:50
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 1                - Your Discr.: 4
             Min tx interval: 20000000   - Min rx interval: 20000000
             Min Echo interval: 250000

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.1.1                                       5/9          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.4.4
Handle: 6
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 671(0), Hello (hits): 250(4683)
Rx Count: 4679, Rx Interval (ms) min/max/avg: 1/259/222 last: 79 ms ago
Tx Count: 4686, Tx Interval (ms) min/max/avg: 11/260/221 last: 95 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:17:18
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 9                - Your Discr.: 5
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.2.2                                       6/7          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.4.4
Handle: 4
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 572(0), Hello (hits): 250(4682)
Rx Count: 4676, Rx Interval (ms) min/max/avg: 1/262/222 last: 178 ms ago
Tx Count: 4685, Tx Interval (ms) min/max/avg: 5/258/222 last: 34 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:17:18
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 7                - Your Discr.: 6
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.3.3                                       7/8          Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.4.4
Handle: 5
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 696(0), Hello (hits): 250(4676)
Rx Count: 4681, Rx Interval (ms) min/max/avg: 1/259/221 last: 54 ms ago
Tx Count: 4679, Tx Interval (ms) min/max/avg: 3/258/222 last: 53 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:17:18
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 8                - Your Discr.: 7
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

IPv4 Multihop Sessions
NeighAddr[vrf]                                LD/RD         RH/RS     State
24.0.5.5                                       8/13         Up        Up
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.4.4
Handle: 3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 601(0), Hello (hits): 250(4682)
Rx Count: 4678, Rx Interval (ms) min/max/avg: 1/283/222 last: 149 ms ago
Tx Count: 4685, Tx Interval (ms) min/max/avg: 7/257/222 last: 104 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: BGP
Map information:
 Destination[vrf]: 24.0.0.0/16
 Source[vrf]: 24.0.0.0/16
 Template: MH
 Authentication(Type/Keychain): invalid_type/
Uptime: 00:17:18
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 13               - Your Discr.: 8
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0


Tuesday, January 16, 2018

BFD task #1.

Topology:




Configure loopback0 interfaces and links between routers according to topology diagram.
All routers are IOS.

Requirements: 

1. Configure all interfaces on all routers in OSPF area 0. Use Broadcast network type on all  ethernet     interfaces, and point-to-point on loopback interfaces. 
2. All traffic shall be forwarded via VLANs 10 and 20 when possible, and use VLANs 30 and 40 as       backup. Do not use interface "bandwidth" command. 
3. Configure the routers, such that Hosts on VLANs 30 and 40 cannot send any packets with spoofed     source address. 
4. Configure the network for sub-second convergence without changing the default OSPF timers. 
5. On routers R1 and R2, use a single command to enable BFD on all OSPF interfaces. 

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of BFD configuration for IGP,  and  understanding BFD echo and no echo modes.

Requirement #1 and #2: configure OSPF on all interfaces, increase the OSPF cost on interfaces R2-R4 and R1-R5 to make this path less preferable compared to other links.

Requirement #3 - configure uRPF on routers R2, R4, R1, and R5, facing the VLANs 30 and 40.
Requirement #4 - disable "BFD echo" mode on VLAN 30 and VLAN 40 interfaces, to allow BFD to work along the uRPF configuration.

R1: 


!
interface Loopback0
 ip address 24.0.1.1 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 24.0.10.1 255.255.255.0
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
interface Ethernet0/1
 ip address 24.0.40.1 255.255.255.0
 ip verify unicast source reachable-via rx
 ip ospf 1 area 0
 ip ospf cost 100
 bfd interval 250 min_rx 250 multiplier 3
 no bfd echo
!
!
router ospf 1
 router-id 24.0.1.1
 bfd all-interfaces
!


R2:


!
interface Loopback0
 ip address 24.0.2.2 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 24.0.10.2 255.255.255.0
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
interface Ethernet0/1
 ip address 24.0.30.2 255.255.255.0
 ip verify unicast source reachable-via rx
 ip ospf 1 area 0
 ip ospf cost 100
 bfd interval 250 min_rx 250 multiplier 3
 no bfd echo
!
!
router ospf 1
 bfd all-interfaces
!

R3: 


!
interface Loopback0
 ip address 24.0.3.3 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 24.0.10.3 255.255.255.0
 ip ospf bfd
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
interface Ethernet0/1
 ip address 24.0.20.3 255.255.255.0
 ip ospf bfd
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
!
router ospf 1
 router-id 24.0.3.3
!


R4:


!
interface Loopback0
 ip address 24.0.4.4 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 24.0.20.4 255.255.255.0
 ip ospf bfd
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
interface Ethernet0/1
 ip address 24.0.30.4 255.255.255.0
 ip verify unicast source reachable-via rx
 ip ospf bfd
 ip ospf 1 area 0
 ip ospf cost 100
 bfd interval 250 min_rx 250 multiplier 3
 no bfd echo
!
!
router ospf 1
 router-id 24.0.4.4
!

R5:


!
interface Loopback0
 ip address 24.0.5.5 255.255.255.255
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 24.0.20.5 255.255.255.0
 ip ospf bfd
 ip ospf 1 area 0
 bfd interval 250 min_rx 250 multiplier 3
!
interface Ethernet0/1
 ip address 24.0.40.5 255.255.255.0
 ip verify unicast source reachable-via rx
 ip ospf bfd
 ip ospf 1 area 0
 ip ospf cost 100
 bfd interval 250 min_rx 250 multiplier 3
 no bfd echo
!
!
router ospf 1
 router-id 24.0.5.5
!

Verification:


R1#             show bfd neighbors

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.2                               1/2          Up        Up        Et0/0
24.0.10.3                               8/8          Up        Up        Et0/0
24.0.40.5                               6/6          Up        Up        Et0/1


R1#sho ip ospf neighbor  detail
 Neighbor 24.0.2.2, interface address 24.0.10.2
    In the area 0 via interface Ethernet0/0, BFD enabled
    Neighbor priority is 1, State is FULL, 6 state changes
    DR is 24.0.10.1 BDR is 24.0.10.2
    Options is 0x12 in Hello (E-bit, L-bit)
    Options is 0x52 in DBD (E-bit, L-bit, O-bit)
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:39
    Neighbor is up for 00:44:31
    Index 1/1, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
 Neighbor 24.0.3.3, interface address 24.0.10.3
    In the area 0 via interface Ethernet0/0, BFD enabled
    Neighbor priority is 1, State is FULL, 6 state changes
    DR is 24.0.10.1 BDR is 24.0.10.2
    Options is 0x12 in Hello (E-bit, L-bit)
    Options is 0x52 in DBD (E-bit, L-bit, O-bit)
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:30
    Neighbor is up for 00:14:20
    Index 2/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
 Neighbor 24.0.5.5, interface address 24.0.40.5
    In the area 0 via interface Ethernet0/1, BFD enabled
    Neighbor priority is 1, State is FULL, 6 state changes
    DR is 24.0.40.5 BDR is 24.0.40.1
    Options is 0x12 in Hello (E-bit, L-bit)
    Options is 0x52 in DBD (E-bit, L-bit, O-bit)
    LLS Options is 0x1 (LR)
    Dead timer due in 00:00:38
    Neighbor is up for 00:18:27
    Index 3/3, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec

R1# sho bfd neighbors details

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.2                               1/2          Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.10.1
Handle: 1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 1000(1549)
Rx Count: 1499, Rx Interval (ms) min/max/avg: 1/1006/877 last: 600 ms ago
Tx Count: 1550, Tx Interval (ms) min/max/avg: 1/1005/880 last: 383 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:21:54
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 2                - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.10.3                               8/8          Up        Up        Et0/0
Session state is UP and using echo function with 250 ms interval.
Session Host: Software
OurAddr: 24.0.10.1
Handle: 2
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holddown (hits): 0(0), Hello (hits): 1000(1030)
Rx Count: 1032, Rx Interval (ms) min/max/avg: 1/1006/877 last: 566 ms ago
Tx Count: 1032, Tx Interval (ms) min/max/avg: 1/1004/877 last: 521 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:15:05
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 8                - Your Discr.: 8
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 250000

IPv4 Sessions
NeighAddr                              LD/RD         RH/RS     State     Int
24.0.40.5                               6/6          Up        Up        Et0/1
Session state is UP and not using echo function.
Session Host: Software
OurAddr: 24.0.40.1
Handle: 3
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 250000, MinRxInt: 250000, Multiplier: 3
Received MinRxInt: 250000, Received Multiplier: 3
Holddown (hits): 525(0), Hello (hits): 250(5199)
Rx Count: 5183, Rx Interval (ms) min/max/avg: 16/260/223 last: 225 ms ago
Tx Count: 5201, Tx Interval (ms) min/max/avg: 1/257/221 last: 2 ms ago
Elapsed time watermarks: 0 0 (last: 0)
Registered protocols: OSPF
Uptime: 00:19:11
Last packet: Version: 1                  - Diagnostic: 0
             State bit: Up               - Demand bit: 0
             Poll bit: 0                 - Final bit: 0
             C bit: 0
             Multiplier: 3               - Length: 24
             My Discr.: 6                - Your Discr.: 6
             Min tx interval: 250000     - Min rx interval: 250000
             Min Echo interval: 0

Wednesday, January 10, 2018

Overlay VPN task #9. LISP part 2.

Topology:



Use configuration from Overlay VPN task #8 as initial configuration for this task.

Requirements: 

Site A has been allocated an IPv6 prefix 2001:1::/32.
Site B has been allocated an IPv6 prefix 2001:3::/32.

1. Enable IPv6 routing on routers R1,R2, R3 and R4.
2. Use the following networks to connect the devices:
R1-R2: 2001:1:0:12::/64
R3-R4: 2001:3:0:34::/64
3. Configure static default route to provide connectivity for routers R2 and R4.
4. Configure the  network to provide IPv6 connectivity between Site 1 and Site 2.
5. Do not enable IPv6 routing on routers R5, R6, R8 and R9.
6. Do not use "interface tunnel" command. 

Solution:

Highlight the text below to reveal the solution.

This solution requires understanding of LISP configuration with IPv4 and IPv6 EID addresses.

Note that this type of solution can be used as IPv6 transition mechanism, when use of arbitrary IPv6 prefixes at each site is required.

R1:


ipv6 unicast-routing
!
interface Ethernet0/2
 ip address 10.1.12.1 255.255.255.0
 ipv6 address 2001:1:0:12::1/64
!
!
router lisp
 database-mapping 10.1.0.0/16 35.0.15.1 priority 100 weight 50
 database-mapping 10.1.0.0/16 38.0.18.1 priority 100 weight 50
 database-mapping 2001:1::/32 35.0.15.1 priority 100 weight 50
 database-mapping 2001:1::/32 38.0.18.1 priority 100 weight 50
 ipv4 itr map-resolver 35.0.57.7
 ipv4 itr map-resolver 39.0.109.10
 ipv4 itr
 ipv4 etr map-server 35.0.57.7 key STRONG
 ipv4 etr map-server 39.0.109.10 key STRONG
 ipv4 etr
 ipv6 itr map-resolver 35.0.57.7
 ipv6 itr map-resolver 39.0.109.10
 ipv6 itr
 ipv6 etr map-server 35.0.57.7 key STRONG
 ipv6 etr map-server 39.0.109.10 key STRONG
 ipv6 etr
 exit
!


R2:


ipv6 unicast-routing
!
interface Ethernet0/0
 ip address 10.1.12.2 255.255.255.0
 ipv6 address 2001:1:0:12::2/64
!
ipv6 route ::/0 2001:1:0:12::1


R3:


ipv6 unicast-routing
!
interface Ethernet0/2
 ip address 10.3.34.3 255.255.255.0
 ipv6 address 2001:3:0:34::3/64
!
!
router lisp
 database-mapping 10.3.0.0/16 36.0.36.3 priority 100 weight 50
 database-mapping 10.3.0.0/16 39.0.39.3 priority 100 weight 50
 database-mapping 2001:3::/32 36.0.36.3 priority 100 weight 50
 database-mapping 2001:3::/32 39.0.39.3 priority 100 weight 50
 ipv4 itr map-resolver 35.0.57.7
 ipv4 itr map-resolver 39.0.109.10
 ipv4 itr
 ipv4 etr map-server 35.0.57.7 key STRONG
 ipv4 etr map-server 39.0.109.10 key STRONG
 ipv4 etr
 ipv6 itr map-resolver 35.0.57.7
 ipv6 itr map-resolver 39.0.109.10
 ipv6 itr
 ipv6 etr map-server 35.0.57.7 key STRONG
 ipv6 etr map-server 39.0.109.10 key STRONG
 ipv6 etr
 exit
!


R4:

ipv6 unicast-routing
!
interface Ethernet0/0
 ip address 10.3.34.4 255.255.255.0
 ipv6 address 2001:3:0:34::4/64
!
ipv6 route ::/0 2001:3:0:34::3


R7 & R10:


!
vrf definition MRMS
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
router lisp
 site S1
  authentication-key STRONG
  eid-prefix 10.1.0.0/16
  eid-prefix 2001:1::/32
  exit
 !
 site S3
  authentication-key STRONG
  eid-prefix 10.3.0.0/16
  eid-prefix 2001:3::/32
  exit
 !
 ipv4 map-server
 ipv4 map-resolver
 ipv4 alt-vrf MRMS
 ipv6 map-server
 ipv6 map-resolver
 ipv6 alt-vrf MRMS
 exit
!




Verification:


R2#traceroute 2001:3:0:34::4
Type escape sequence to abort.
Tracing the route to 2001:3:0:34::4

  1 2001:1:0:12::1 20 msec 5 msec 5 msec
  2 2001:3:0:34::3 1 msec 0 msec 0 msec
  3 2001:3:0:34::4 37 msec 5 msec 4 msec